Unknown reporter writes

 File "/usr/share/recoll/filters/rclzip", line 75
    except Exception, err:
                    ^
SyntaxError: invalid syntax

And zip files not index.

Workaround Change #!/usr/bin/env python to #!/usr/bin/python2 in /usr/share/recoll/filters/rclzip

medoc writes

Using your workaround as a permanent fix would risk breaking old systems. For example Debian 6 has no python2 command by default as far as I can see. So, no, sorry, not possible. The right approach would be to make the scripts compatible with both python2 and python3, which is usually not too hard, but I don’t have the time at the moment.